User:Gapaloga

From Rosetta Code
Revision as of 01:54, 22 June 2020 by rosettacode>Gapaloga (Created page with "Algoritmo Calculadora_Prestamos_Bancarios Escribir "***************************************************************" Escribir "*...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Algoritmo Calculadora_Prestamos_Bancarios Escribir "***************************************************************" Escribir "* *" Escribir "* Bienvenido al Banco Moon *" Escribir "* *" Escribir "***************************************************************" Escribir "" Escribir "" Escribir "" Escribir " _______________________________ " Escribir " | | " Escribir " ________| MMMMM OOOOO OOOOO NN N |_______" Escribir " \ | M M M O O O O N N N | /" Escribir " \ | M M M OOOOO OOOOO N NN | / " Escribir " / |_______________________________| \ " Escribir " /__________) (__________\" Escribir "" Escribir "" Escribir "" Repetir Escribir "Favor digite su usuario:" Leer vUsuario Limpiar Pantalla Escribir "Favor ingrese su contraseña estimado: ", vUsuario Leer vContrasenna Si vUsuario != "admin" Entonces Escribir "El usuario no es correcto, por favor validar." Limpiar_datos_ingreso SiNo Si vContrasenna != "12345" Entonces Escribir "La contraseña no es correcta, por favor validar." Limpiar_datos_ingreso SiNo vUsuarioValido <- "V" FinSi Fin Si Hasta Que vUsuarioValido = "V" Limpiar Pantalla Repetir Escribir "***************************************************************" Escribir "* *" Escribir "* Menú Principal del Banco *" Escribir "* *" Escribir "***************************************************************"

Escribir "" Escribir "Coloque el número de la opción a la cual desea ingresar" Escribir "" Escribir "(1) Contacto. " Escribir "(2) Información. " Escribir "(3) Calculadora de prestamos. " Escribir "(4) Logout. "

Leer vOpcionMenu Segun vOpcionMenu Hacer "1": Contacto Limpiar_Opciones_Menu "2": Informacion_creditos Limpiar_Opciones_Menu "3": Limpiar Pantalla Repetir Escribir "***************************************************************" Escribir "* *" Escribir "* Menú calculadora de préstamos *" Escribir "* *" Escribir "***************************************************************" Escribir "" Escribir "Siga los pasos que se le mostraran a continuación:" Escribir "" Repetir Limpiar Pantalla Escribir "(Paso #1) Seleccionar el tipo de crédito: " Escribir "(a)Personal." Escribir "(b)Prendario." Escribir "(c)Hipotecario." leer vTipoPrestamo Segun vTipoPrestamo Hacer "a": vDescTipoPrestamo <-"Personal" vTasa <- 0.338 vDescTasa <- "33.80%" vExiteTipo <- "V" "b": vDescTipoPrestamo <-"Prendario" vTasa <- 0.183 vDescTasa <- "18.30%" vExiteTipo <- "V" "c": vDescTipoPrestamo <- "Hipotecario" vTasa <- 0.16 vDescTasa <- "16.00%" vExiteTipo <- "V" De Otro Modo: Escribir"Debe seleccionar una opción válida." vExiteTipo <- "F" Escribir "Presione cualquier tecla para ingresar el valor nuevamente." Esperar Tecla Fin Segun Hasta Que vExiteTipo = "V" Limpiar Pantalla Repetir Limpiar Pantalla Escribir "(Paso #2) Seleccione el tipo de moneda:" Escribir "(a)Dólares" Escribir "(b)Colones" Leer vMoneda Segun vMoneda Hacer "a": vDescMoneda <-"Dólares" vExiteMoneda <- "V" "b": vDescMoneda <-"Colones" vExiteMoneda <- "V" De Otro Modo: Escribir"Debe seleccionar una opción válida." vExiteMoneda <- "F" Escribir "Presione cualquier tecla para ingresar el valor nuevamente." Esperar Tecla

Fin Segun Hasta Que vExiteMoneda = "V" Limpiar Pantalla Escribir "(Paso #3) Introduce el monto solicitado, solo números." Leer vMonto Limpiar Pantalla Escribir "(Paso #4) Introduce el plazo (meses), solo números" Leer vPlazo Limpiar Pantalla Escribir "Un momento por favor..." Escribir "" vCuotaMensual<-Calculadora (vMonto, vPlazo, vTasa) Escribir "Su cuota mensual para su préstamo: ", vDescTipoPrestamo, " es de: ", vCuotaMensual," ", vDescMoneda "." Escribir "Su tasa mensual es de: ", vDescTasa, "." Escribir "" Escribir "Presione la tecla 9 se desea salir al menú principal." Escribir "De lo contrario, pulse cualquier otra tecla para empezar de nuevo el proceso de calculo" Leer vOpcionSalida Limpiar Pantalla Hasta Que vOpcionSalida = "9" Limpiar Pantalla "4": Escribir "*****Hasta luego, lo esperamos pronto.******" Escribir "" De Otro Modo: Escribir "Debe seleccionar una opción válida." Limpiar_Opciones_Menu Fin Segun Hasta Que vOpcionMenu = "4"

FinAlgoritmo


SubProceso vCouta <- Calculadora (vMonto, vPlazo, vTasa) //Método frances R = P [(i (1 + i)n) / ((1 + i)n - 1)]

   //Donde:

//R = renta (cuota) //P = principal (préstamo adquirido) //i = tasa de interés //n = número de periodos

vInteres<- vTasa vAux1<- 1+vInteres // (1 + i) vAux2<- vAux1^vPlazo //(1 + i)n vAux3<- vInteres * vAux2 //(i (1 + i)n) vAux4<- vAux2 - 1 //(((1 + i)n -1) vAux5<- vAux3 / vAux4 //[(i (1 + i)n) / ((1 + i)n -1)] vCouta<- vMonto * vAux5 //P [(i (1 + i)n) / ((1 + i)n – 1)] FinSubProceso

SubProceso Limpiar_datos_ingreso vUsuarioValido <- "F" Escribir "Presione cualquier tecla para volver a ingresar los datos." Esperar Tecla Limpiar Pantalla FinSubProceso

SubProceso Limpiar_Opciones_Menu Escribir "Presione cualquier tecla para volver al menú principal." Esperar Tecla Limpiar Pantalla FinSubProceso

Subproceso Contacto Limpiar Pantalla Escribir "***************************************************************" Escribir "* *" Escribir "* Información del contacto *" Escribir "* *" Escribir "***************************************************************" Escribir "" Escribir "Nombre: Gaudy Lopez Gamboa" Escribir "------" Escribir "" Escribir "Correo electrónico: gaudypao@gmail.com" Escribir "-------------------" Escribir "" Escribir "Teléfono: 7271-1566" Escribir "--------" Escribir "" Escribir "Dirección: 20 oeste de calle taravilla" Escribir "---------" Escribir "" Escribir "" FinSubProceso

Subproceso Informacion_creditos Limpiar Pantalla Escribir "***************************************************************" Escribir "* *" Escribir "* Información de créditos *" Escribir "* *" Escribir "***************************************************************" Escribir "" Escribir "Crédito Hipotecario " Escribir "--------------------" Escribir "" Escribir "Es una línea de crédito, en colones o en dólares para generadores " Escribir "y no generadores creada para satisfacer diversos gastos personales." Escribir "La línea tiene un tope máximo de $150.000 en colones y dólares, a " Escribir "un plazo de 20 años en colones y de 15 años en dólares." Escribir "" Escribir "Tasa de un 16.00% mensual" Escribir "" Escribir "En colones se financia un 80% cuando existe construcción y un 70% " Escribir "en caso de lote, en dólares únicamente se financia un 70% del valor " Escribir "del avalúo." Escribir "" Escribir "" Escribir "Crédito Personal " Escribir "--------------------" Escribir "" Escribir "Este financiamiento es para clientes asalariados. " Escribir "El monto mínimo 300 mil colones." Escribir "El monto máximo será de ¢7.5 millones de colones para clientes nuevos." Escribir "El monto máximo será de ¢15 millones de colones para clientes vigentes" Escribir "de crédito." Escribir "" Escribir "Tasa de interés: 33.80% mensual." Escribir "Plazo en meses: 96. " Escribir "" Escribir "" Escribir "Crédito Prendario " Escribir "--------------------" Escribir "" Escribir "Tasas mensuales:" Escribir "Enganche: Del 15.00% al 19.99% , tasa C: 18.30% , tasa $: 17.45%" Escribir "Enganche: Del 20.00 al 29.99%, tasa C: 18.14%, tasa $: 17.35%" Escribir "Enganche: Del 30 al 49.99%, tasa C: 17.90%, tasa $: 17.25%" Escribir "Enganche: 50.00% o más, tasa C: 17.65%, tasa $: 16.99%" Escribir "" Escribir "Beneficios" Escribir "48 hrs en la aprobación de su crédito." Escribir "Seguro mensual a través de póliza Colectiva." Escribir "Asesoría en el trámite del crédito y servicio personalizado." Escribir "" Escribir "Detalles del financiamiento:" Escribir "Financiamiento hasta entre 80% y 75% del valor del vehículo" Escribir "Plazos: Desde 72 a 96 meses dependiendo del modelo del vehículo. " Escribir "Garantía: prendaria a favor del Banco." Escribir "" Escribir "" Escribir ""

FinSubProceso