Talk:Check output device is a terminal
This might be better named "Check output device is a terminal", or "Check output device is teletype". Rationale: I think we are primarily "checking" device type, rather than "determining what input" or "determining what output" is being obtained or transmitted.
We might be able to merge both the input and output device checks to determine interactivity status. This is just an idea, but it will probably be the way it is implemented in real code.
Markhobley 08:48, 28 March 2013 (UTC)
- +1 on the name change. --Paddy3118 11:18, 28 March 2013 (UTC)